Kehittäjäsivusto

Muutosloki

Kaikki blogimerkinnät

31.10.2017 Ulkonäön ja käytettävyyden päivitys sekä muita pienempiä muutoksia

Tekijä: Juha Lahti
Muutosloki isomman päivityksen jälkeen hiukan jälkijunassa, mutta jatkossa palataan taas normaaliin julkaisutahtiin.

Päivityksen suurin muutos on ulkoasun ja käytettävyyden uudistus. Tämän uudistuksen tärkeimmät kohdat on kuvattu erillisellä sivulla osoitteessa https://peda.net/id/d7c5af32840.

Muita päivityksen mukanaan tuomia muutoksia:
  • Sivuilla käytetään parasta selaimeen valmiiksi asennettua kirjasinleikkausta (eli "fonttia"). Jos Peda.net-palvelun luettavuus on mielestäsi muuttunut päivityksen myötä huonommaksi, niin ota yhteyttä info@peda.net ja kerro mitä selainta ja mitä käyttöjärjestelmää käytät.
  • Info-tv:n ruutujen ajastus.
  • Sivun avaimen muutos lukijan salasanaksi. Tämän muutoksen tavoitteena on tarkoitus estää sekaannuksia liittymisavaimen kanssa. Erona vanhaan toimintaan Lukijan salasana vaikuttaa vain sivun lukijoihin, kun aikaisemmin Sivun avain vaikutti myös sivun osallistujiin.
  • Oman profiilin tehdyt profiilimerkinnät on siirretty omalle sivulleen. Sivu löytyy oman profiilin alta kohdasta "(Vanhat profiilimerkinnät)".
  • HTML5-yhteensopivuutta on parannettu. Tämän pitäisi auttaa erityisesti palvelun esteettömyyttä.
  • Tietoliikenneyhteyksien salausta on muutettu vahvemmaksi (nyt vaaditaan vähintään TLS 1.0).
  • Useita pieniä korjauksia tilanteisiin, jotka ovat koskeneet pientä osaa kaikista käyttäjistä.
  • Lisätty Välitaso-asetuksen merkistystä. Päätasoksi määritellyt sivut määrittelevät sivuston ulkonäön ja välitasot (sekä päätasot) määrittelevät navigoinnin lähtötason. (Jos navigointi on "liian iso" niin asian voi korjata määrittämällä sivuja Välitasoiksi.)

Tunnetut ongelmat eräillä päätelaitteilla:
  • Android-laitteet, joita ei voi päivittää vähintään versioon 4.0.4 eivät pysty toimimaan Peda.netissä, koska nämä eivät tue turvallisia tietoliikenneyhteyksiä. Peda.net suosittelee tällaisten laitteiden käytön lopettamisen internet-palveluissa yleisesti tietoturvariskien takia.
  • Internet Explorer ei pysty muodostamaan turvallista tietoliikenneyhteyttä Peda.net-palveluun Windows XP -käyttöjärjestelmässä. Peda.net suosittelee Windows XP:n käytön lopettamisen internet-palveluissa yleisesti tietoturvariskien takia.
  • Internet Explorer versio 10.0 ja vanhemmat versiot näyttävät Peda.net-palvelun monessa näkymässä väärin. Ongelma korjautuu asentamalla Internet Explorer -selaimen uusimmat tietoturvapäivitykset, joka samalla päivittää selaimen versioon 11.
  • Peda.net-palvelu näkyy väärin yhdistelmällä Safari ja Mac OS 10.13, jos JavaScript kytketään pois päältä selaimen asetuksista. Ongelma johtuu tässä käyttöjärjestelmässä olevasta Safari-selaimen viasta, johon Peda.net on tehnyt väliaikaisen korjauksen JavaScriptin avulla.
  • Mahdollinen ongelma: Firefox 56 ja Windows 10 saattaa joillakin näytönohjaimilla näyttää toimintonappulat väärin. Ongelman tarkka syy on vielä tuntematon. Jos esimerkiksi Muokkaa ja Poista -toiminnot eivät näy Firefox-selaimella, niin pyydämme ottamaan yhteyttä osoitteeseen info@peda.net ja kopioimaan sivun about:support sisällön mukaan viestiin.

Tulevaisuudessa ongelmalliset päätelaitteet:
  • Seuraavat selaimet eivät tue TLS 1.2 salausta, joka mahdollisesti joudutaan ottamaan käyttöön tulevaisuudessa hyvän tietoturvan varmistamiseksi: Android 4.3 ja vanhempi, Internet Explorer 10 ja vanhempi, Windows Phone 8.1 ja vanhempi, Safari 6 ja vanhempi. Nämä selaimet eivät tue TLS 1.2 -standardin mukaista tietoliikenteen salausta ja eivät pysty enää ottamaan yhteyttä Peda.net-palveluun, kun TLS 1.0 -tekniikan käyttö joudutaan lopettamaan. Tämä tulee todennäköisesti tapahtumaan vuoden 2018 aikana.

Kommentit

Kirjaudu sisään lisätäksesi tähän kommentti