Muutoksia salausasetuksissa tammikuussa 2015

Yhteenveto

Salatuissa palvelinyhteyksissä käytettävissä sertifikaateissa ja protokollissa on löydetty haavoittuvuuksia, joiden takia sertifikaatteja ja palvelimien konfiguraatioita on vaihdettava maailmanlaajuisesti. Myös Peda.net tekee nämä tarvittavat muutokset torstaina 15.1.2015.

Selainvalmistajat, Google eturintamassa, alkavat vuoden 2015 aikana aktiivisesti varoitella käyttäjiään haavoittuvia yhteyksiä käyttävistä palveluista. Onkin odotettavaa, että suuremmat ja hyvin ylläpidetyt palvelut päivittyvät nopealla tahdilla.

Suurimmalle osalle käyttäjistä muutokset eivät näy millään tavalla, mutta vanhemmilla selaimilla tai laitteilla päivitettyjen palveluiden käyttö estyy kokonaan.

Selainten yhteensopivuuksista

Kaikkien yleisimpien käyttöjärjestelmien ja selainten uusimmat versiot tukevat kaikkea tarvittavaa automaattisesti ja niiden käyttäjät eivät huomaa muutoksia mitenkään.

Ongelmallisia ympäristöjä, joiden tuki on jo valmistajien puolesta loppunut ja joilla palveluiden käyttö estyy kokonaan muutosten jälkeen ovat:
  • Windows XP ennen SP3-päivitystä
  • Android versiot vanhemmat kuin 2.3
Lisää tietoa yhteensopivuuksista englanniksi:
https://support.globalsign.com/customer/portal/articles/1499561-sha-256-compatibility

Peda.net käyttää vain välttämättömiä evästeitä istunnon ylläpitämiseen ja anonyymiin tekniseen tilastointiin. Peda.net ei koskaan käytä evästeitä markkinointiin tai kerää yksilöityjä tilastoja. Lisää tietoa evästeistä